[Bf-committers] The procedure entry point K32EnumProcesses could not be located in the dynamic link library KERNEL32.dll

Martijn Berger martijn.berger at gmail.com
Sat Jan 2 13:10:37 CET 2016

Hi Jeff,

What you did ( defining PSAPI_VERSION to 1 ) is what we did for the release
build also.
We have stopped supporting vista on x64 as we want to use the AVX
instruction set and that requires operating system level support which is
not present in windows versions prior to Windows 7 SP1.  There crashes that
relate to the msvc common runtime math functions detecting and using AVX
even if they should not. This is beyond our control to fix and given the
fact that we have a lot of users that have modern computers and operating
systems we felt it justified to sunset Vista support on x64.

The nicer way to set this is to set CMAKE_CXX_FLAGS to include this define
using the cmake gui tool.
I hope this helps you and sorry for the possible inconvenience dropping
vista support caused you.

Martijn Berger

On Sat, Jan 2, 2016 at 4:34 AM, The Simple Carnival <jeff at simplecarnival.com
> wrote:

> Hello --
> I've been working with a custom Windows build of Blender 2.75. I'm using
> Visual Studio 2013 Community Edition. The custom build runs on all of my
> computers...except on a Vista machine. When I run the executable on
> Vista (Home Premium x64, SP2 with all the latest Windows Update
> patches), a message box pops up with the title "blender-app.exe - Entry
> Point Not Found" and this error message: "The procedure entry point
> K32EnumProcesses could not be located in the dynamic link library
> KERNEL32.dll." After clicking OK, the app closes.
> When I run the official version of Blender 2.75 x64 on the same machine,
> Blender starts up as it should.
> I did a bit of researching on this error, and I've found this:
> https://msdn.microsoft.com/en-us/library/windows/desktop/ms682631%28v=vs.85%29.aspx
> As suggested by that article, I added -DPSAPI_VERSION=1 to the "blender"
> project preprocessor definitions.
> I came across this post...
> http://stackoverflow.com/questions/29208637/entry-point-not-found-error-in-vista-os/29209415
> ...and made sure that Psapi.lib was already linked in the project.
> After doing a full rebuild, I'm still seeing the same issue. Any
> suggestions on what I have to do to the solution or project(s) to make
> this run on Vista?
> Thank you!
> Jeff Boller
> jeff at simplecarnival.com
> The Simple Carnival -- it doesn't rock, it pops!
> http://www.simplecarnival.com
> http://www.facebook.com/TheSimpleCarnival
> http://twitter.com/simplecarnival
> _______________________________________________
> Bf-committers mailing list
> Bf-committers at blender.org
> http://lists.blender.org/mailman/listinfo/bf-committers

More information about the Bf-committers mailing list