[Bf-committers] CMake minimum version increased to 3.0
montagne29 at wanadoo.fr
Mon Nov 9 21:21:48 CET 2015
This is not correct, actually, install_deps.sh script does install/build
missing dependencies for you, even on pretty old distributions.
We could (as suggested by Campbell this afternoon) do that for CMake as
well (build newer one in install_deps.sh if needed),
but this is a bit a different case, user would not be able to use
`cmake` directly from commandline, they’d have to remember
the path to the built cmake, would likely lead to a bunch of complains...
Le 09/11/2015 21:17, Stephen Kelly a écrit :
> On 11/09/2015 05:04 PM, Campbell Barton wrote:
>> It turns out Ubuntu 14.10 still users CMake 2.8, so better not break
>> building for one year old distros,
> Yesterday I was a user of Ubuntu 15.04 and I could not build blender.
> blender depends on openexr 2.2 which only appears in 15.10:
> So, already you can't build blender on an ubuntu release which was 'the
> most recent ubuntu release' 3 weeks ago!
> You need to either upgrade to 15.10 (that's what I did), or install the
> new version of openexr some other way on 15.04.
> I don't see why cmake should be handled particularly differently.
> Ubuntu 15.10 has CMake 3.2.2.
> Bf-committers mailing list
> Bf-committers at blender.org
More information about the Bf-committers