[Bf-committers] CMake minimum version increased to 3.0

Stephen Kelly steveire at gmail.com
Mon Nov 9 21:27:05 CET 2015

On 11/09/2015 09:21 PM, Bastien Montagne wrote:
> This is not correct, actually, install_deps.sh script does install/build 
> missing dependencies for you, even on pretty old distributions.

I think you missed the 'some other way' part of what I wrote :). That's
correct, right?

> >
> > You need to either upgrade to 15.10 (that's what I did), or install the
> > new version of openexr some other way on 15.04.

> We could (as suggested by Campbell this afternoon) do that for CMake as 
> well (build newer one in install_deps.sh if needed),
> but this is a bit a different case, user would not be able to use 
> `cmake` directly from commandline, they’d have to remember
> the path to the built cmake, would likely lead to a bunch of complains...

I didn't really look into the script, how people are expected to use it,
what it does etc, but I believe what you say is true. Is it solvable?



More information about the Bf-committers mailing list