[Bf-committers] RNA Rename Proposal

Brecht Van Lommel brecht at blender.org
Tue Aug 17 12:33:55 CEST 2010

Hi Campbell,

Thanks for doing this tedious work. I read over the list, noticed these.


Actuator|SoundActuator.max_distance_3d -> distance_3d_max:   float
"The maximum distance at which you can hear the sound"
Actuator|SoundActuator.reference_distance_3d -> distance_rest_3d:
float  "The distance where the sound has a gain of 1.0"

    I would use distance_3d_rest for consistency with distance_3d_max.

ColorRamp.total -> count:   int,  "(read-only)    Total number of elements"

    Property should be removed, can use len(ramp.elements).

FluidSettings|DomainFluidSettings.real_world_size -> size_worldspace:
 float  "Size of the simulation domain in metres"

    Don't think this new name is right, looks light some scale factor
for physical units?

ID|Material.roughness -> rough:   float  "Oren-Nayar Roughness"
ID|Material.specular_hardness -> specular_hard:   int  "NO DESCRIPTION"
TextureSlot|MaterialTextureSlot.hardness_factor -> hard_factor:
float  "Amount texture affects hardness"

    Would not change these names, "roughness" is a standard name, but
perhaps a matter of preference.

ID|MetaBall.render_size -> render_detail:   float  "Polygonization
resolution in rendering"
ID|MetaBall.wire_size -> viewport_detail:   float  "Polygonization
resolution in the 3D viewport"

    Would use "resolution" instead of "detail".

 ID|ParticleSettings.ren_as -> render_method:   enum  "How particles
are rendered"

    Would use "type" instead of "method" here.

ID|Texture|CloudsTexture.stype -> subtype:   enum  "NO DESCRIPTION"
ID|Texture|MarbleTexture.stype -> subtype:   enum  "NO DESCRIPTION"
ID|Texture|StucciTexture.stype -> subtype:   enum  "NO DESCRIPTION"
ID|Texture|VoronoiTexture.coloring -> color_mode:   enum  "NO DESCRIPTION"
ID|Texture|WoodTexture.stype -> subtype:   enum  "NO DESCRIPTION"

    Would use "color_type", "marble_type", "stucci_type",
"voronoi_type" and "wood_type".

PointDensity.vertices_cache -> vertex_cache_coords:   enum
"Co-ordinate system to cache vertices in"
PointDensity.particle_cache -> particle_cache_coords:   enum
"Co-ordinate system to cache particles in"

    Would use "space" instead of "coords"

MaterialVolume.lighting_mode -> light_mode:   enum  "Method of
shading, attenuating, and scattering light through the volume"

    Would use "method" instead of "mode".

More information about the Bf-committers mailing list