[Bf-committers] Re: Re: MBall transform & Displist problems

GSR - FR famrom at infernal-iceberg.com
Tue Apr 12 00:11:03 CEST 2005

theeth at yahoo.com (2005-04-11 at 1441.54 -0700):
> > > 1) In the new metaball transform code (which is
> > nice, btw), clicking
> > > MMB to constrain to an axis (inside editmode, to
> > scale elems like
> > > tube) does *not* cancel the previous transform,
> > unlike all other
> > > editmodes. This is confusing.
> > 
> > That happens with all transforms now, not just
> > mballs and not just
> > edit mode. It is a functionality regresion, only way
> > to get out of it
> > is full cancel or press keys two times. Maybe three
> > times, it seems
> > first is ignored here.
> Even after my update?
> Works flawlessly here (and more so, the update only
> affected mballs, as it always worked ok with the
> rest).

Updated cvs, and constraint of scale of a single mball makes it back
to start size and not scale any axis, but that seems to be a
limitation of the mball sphere, cos mball cube works.

Being unable to get out of constraint with mouse only still there,
tried grab with the mball cube. Top view and constraint X started via
MB2 axis (header says global), then had to press X (global), X again
(local) and another X (free). For Y axis by pressing MB2 (global), one
Y (local), a second Y (global ?) and another Y (free).

Repeated with monkey mesh, in and out of edit mode, same result about
unable to unlock with mouse, having to press keys a lot and strange
order in Y case.


More information about the Bf-committers mailing list