[Bf-codereview] Tiles Compositing Branch (issue 6199066)

j.bakker at atmind.nl j.bakker at atmind.nl
Fri May 11 15:58:47 CEST 2012


Also added your remarks as issues in the issue tracker.


http://codereview.appspot.com/6199066/diff/6071/source/blender/blenloader/intern/readfile.c
File source/blender/blenloader/intern/readfile.c (right):

http://codereview.appspot.com/6199066/diff/6071/source/blender/blenloader/intern/readfile.c#newcode13064
source/blender/blenloader/intern/readfile.c:13064: if
(node->type==CMP_NODE_R_LAYERS) {
On 2012/05/11 13:36:47, brechtvl wrote:
> For a moment here I thought this code was wrong, because it didn't go
into node
> groups, but it seems render layer nodes are not allowed in node
groups. Still
> might be good to add a comment about that exception here.

See your comment about the NodeRenderLayerData. this part will be
removed due to no usage atm. (is part of canvas compositing)

http://codereview.appspot.com/6199066/diff/6071/source/blender/makesrna/intern/rna_nodetree.c
File source/blender/makesrna/intern/rna_nodetree.c (right):

http://codereview.appspot.com/6199066/diff/6071/source/blender/makesrna/intern/rna_nodetree.c#newcode1447
source/blender/makesrna/intern/rna_nodetree.c:1447: {3, "NOT",
0, "Not",           ""},
On 2012/05/11 13:36:47, brechtvl wrote:
> Can we find a better name than "Not"? It's not clear to what such an
operation
> would do. Or at least fill in the tooltip then.

> Also in this enum and a few others in this file, hardcoded number
values are
> used, while e.g. CMP_NODE_MASKTYPE_ADD is defined.
Oke, will add defines to dna and perhaps difference/union/exclusion is a
better name for masking.

http://codereview.appspot.com/6199066/diff/6071/source/blender/nodes/composite/node_composite_tree.c
File source/blender/nodes/composite/node_composite_tree.c (right):

http://codereview.appspot.com/6199066/diff/6071/source/blender/nodes/composite/node_composite_tree.c#newcode140
source/blender/nodes/composite/node_composite_tree.c:140:
node->new_node->id= (ID *)node->id;
On 2012/05/11 13:36:47, brechtvl wrote:
> What is the reason for this change?
To have direct feedback to the viewer/backdrop the compositor writes
directly to the imagebuffer of the viewernode. This cannot be the copy
of that image buffer as the UI is not looking to that instance.

http://codereview.appspot.com/6199066/


More information about the Bf-codereview mailing list