[Bf-codereview] Camera tracking integration (issue 5285047)

brechtvanlommel at gmail.com brechtvanlommel at gmail.com
Wed Oct 19 19:55:02 CEST 2011


http://codereview.appspot.com/5285047/diff/3001/release/scripts/startup/bl_ui/properties_object_constraint.py
File release/scripts/startup/bl_ui/properties_object_constraint.py
(right):

http://codereview.appspot.com/5285047/diff/3001/release/scripts/startup/bl_ui/properties_object_constraint.py#newcode757
release/scripts/startup/bl_ui/properties_object_constraint.py:757:
layout.prop(con, "use_default_clip")
I think this property should be named "active clip" rather than "default
clip"?

http://codereview.appspot.com/5285047/diff/3001/source/blender/blenkernel/BKE_movieclip.h
File source/blender/blenkernel/BKE_movieclip.h (right):

http://codereview.appspot.com/5285047/diff/3001/source/blender/blenkernel/BKE_movieclip.h#newcode54
source/blender/blenkernel/BKE_movieclip.h:54: void
BKE_movieclip_acquire_size(struct MovieClip *clip, struct MovieClipUser
*user, int *width, int *height);
These functions are called 'acquire', but i think they should just be
'get'. Reason is that acquire/release naming is used for thread safe
access with locks.

http://codereview.appspot.com/5285047/diff/3001/source/blender/makesrna/intern/rna_movieclip.c
File source/blender/makesrna/intern/rna_movieclip.c (right):

http://codereview.appspot.com/5285047/diff/3001/source/blender/makesrna/intern/rna_movieclip.c#newcode160
source/blender/makesrna/intern/rna_movieclip.c:160: static void
rna_def_moviecliUuser(BlenderRNA *brna)
Small typo here.

http://codereview.appspot.com/5285047/


More information about the Bf-codereview mailing list