[Bf-python] new python development path

Joseph Gilbert jgilbert at tigr.ORG
Thu Feb 9 23:30:45 CET 2006


Campbell Barton wrote:

> Because I have had files messed up that modify objects in non active 
> scenes without me knowing.

Maybe these need better names. Object.GetEveryObject() or something. 
Also Scene.getActiveObjects().

> ob= scn.objects['"MeshOb"]

This goes back to my disscussion with Ken regarding OOP interfaces. 
Again maintaining a list of object pointers is expensive here. However 
'objects' could be a interface object that has overridden tp_mapping 
methods which in turn call Get_ID_From_String(), etc. This requires a 
further discussion of the OOP list/dict interface.

> Options are
> 1) remove direct name access (not IDeal IMHO)
> 2) Keep existing access, not ideal either...
> 3) Somehow make existing access different. 
> Blender.Datablock.Get('Mesh', 'SomeMesh') - and document that its only 
> to be used when using the scene/object/data contexts dont work.
> 4) Just document how not use use direct access in each direct access.

I think that keeping datablocks in conjunction with the object+data 
would be flexible to the user. However, how do you scope 2 objects that 
essentially overlap? If you have Mesh and MeshData what's the difference 
between the two?



More information about the Bf-python mailing list