[Bf-cycles] CUDA error on Azure NC6 VM with Tesla K80

Nathan Letwory nathan at mcneel.com
Sun Dec 11 17:02:42 CET 2016


I have a simple .bat file I use to compile binary CUDA  files on Windows
for the standalone.I'll post it when I get home later tonight.  you can use
it to create them on your workstation,  then upload to your azure platform

On 11 Dec 2016 3:16 p.m., "Prayaag Kasundra" <prayaag at decorastudio.com>
wrote:

> Hi,
>
>
>
> -I do compile cycles standalone myself. But that’s on my workstation.
> Doing that on Azure VM will be kind of difficult (installing visual studio
> etc in VM) .
>
> -The Cycles executable I am using on Azure VM was built/compiled from 1.7.0
> tag
> <http://t.sidekickopen61.com/e1t/c/5/f18dQhb0S7lC8dDMPbW2n0x6l2B9nMJW7t5XX463JTCKW8p-VBW4WYH62W3MhGXn56dDfZf8fcGzM02?t=https%3A%2F%2Fdeveloper.blender.org%2Fdiffusion%2FC%2Fbrowse%2Fmaster%2F%3Bv1.7.0&si=4580378421231616&pi=8350d83e-5482-46bf-aaa9-f8d63c870dc6>
> from Cycles repository
>
> -The cubin files was copied from   blender-2.78-62a2ed9-win64.zip on
> https://builder.blender.org/download/
>
>
>
> I am not sure the blender zip I copied the file from and the cycles commit
> I built the cycles from match or not. Please tell me which version of
> blender I should copy from for cycles built from 1.7.0 tag from cycles
> repository. Also is there any standard way to determine which cycles commit
> matches which blender build version ?
>
>
>
> Also it would be great if someone can publish cycles standalone releases
> (executables) for every blender releases. The executables which works with
> all ranges of CUDA devices.
>
>
>
> Thanks,
>
> Prayaag
>
>
>
> On Sun, Dec 11, 12:39 PM, Thomas Dinges <blender at dingto.org> wrote:
>
>
>
> > My best guess is, that the binary, which you copied, doesn't match the
>
> > Cycles version of the standalone repository.
>
> >
>
> > Make sure they match, then it should work. Do you compile Cycles
>
> > standalone yourself? Then you should be able to compile the
>
> > corresponding CUDA kernel alongside.
>
> >
>
> >
>
> >Am 11.12.2016 um 08:42 schrieb Prayaag Kasundra:
>
> >>
>
> >>* We are trying to run cycles on new Azure N series (NC6 ) Virtual *
>
> >>* Machines which has Nvidia Tesla K80 GPUs*
>
> >>
>
> >>* -I created fresh new VM with Windows Server 2016 OS and installed *
>
> >>* Tesla K80 drivers from Nvidia website*
>
> >>
>
> >>* -I installed CUDA tookit 8.0 (Win 10 installer)*
>
> >>
>
> >>* - Now after running –list-devices option I saw K80 in the device list *
>
> >>* along with CPU .*
>
> >>
>
> >>* -After that I ran a render with device=cuda and got this error *
>
> >>* http://prntscr.com/dhz3g9 <http://prntscr.com/dhz3g9> . So I copied kernel_sm_37.cubin file from *
>
> >>* blender/scripts/addon/cycles/bin folder of latest blender build zip.*
>
> >>
>
> >>* - After that the above error went away but then new error appeared *
>
> >>* http://prntscr.com/dhz3wd <http://prntscr.com/dhz3wd>*
>
> >>
>
> >>* How do I fix this ? Please help.*
>
> >>
>
> >>* Thanks,*
>
> >>
>
> >>* Prayaag*
>
> >>
>
> >>
>
> >>
>
> >>* _______________________________________________*
>
> >>* Bf-cycles mailing list*
>
> >>* Bf-cycles at blender.org <http://t.sidekickopen61.com/e1t/c/5/f18dQhb0S7lC8dDMPbW2n0x6l2B9nMJW7t5XX463JTCKW8p-VBW4WYH62W3MhGXn56dDfZf8fcGzM02?t=https%3A%2F%2Flists.blender.org%2Fmailman%2Flistinfo%2Fbf-cycles&si=4580378421231616&pi=8350d83e-5482-46bf-aaa9-f8d63c870dc6>*
>
> >>* https://lists.blender.org/mailman/listinfo/bf-cycles <https://lists.blender.org/mailman/listinfo/bf-cycles>*
>
>
>
> _______________________________________________
> Bf-cycles mailing list
> Bf-cycles at blender.org
> https://lists.blender.org/mailman/listinfo/bf-cycles
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.blender.org/pipermail/bf-cycles/attachments/20161211/fba4f219/attachment.htm 


More information about the Bf-cycles mailing list