[Bf-committers] Scons building under Ubuntu broken

Sam samit_all at libero.it
Thu Sep 4 22:31:17 CEST 2014

indeed, I used to compile with scons using "python scons/scons.py"
and I had no need to use make at all. The problem is scons building is broken
since a few weeks now and it can't produce the needed executable anymore...

>As far as I know you should not have to type "make" after "scons"; scons
>builds everything for you, you should then have a working executable!

>On Wed, 2014-09-03 at 23:15 +0200, Sam wrote:
> >Same error here (Ubuntu 14.04 64bits).
> >Anyway after that error you can do "make" and it will complete the
> >compilation successfully. But yes, the scons one is broken (for me too
> >at least).
> >
> >Regards
> >
> >Vicente
> in my case "make" after "scons" doesn't work.
> it works if I compile with it from scratch, instead.
> >Same here, Linux Mint 17, fresh system install:
> >
> >Linking program ==> 'blender'
> >/usr/bin/ld: /home/piotao/blender-git/deps/oiio/lib/libOpenImageIO.so:
> >undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
> >/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libdl.so: error
> >adding symbols: DSO missing from command line
> >collect2: error: ld returned 1 exit status
> >scons: *** [/home/piotao/blender-git/build/linux/bin/blender] Error 1
> >scons: building terminated because of errors.
> >
> >Installing libopenimageio-dev from distro also did not help. But after this
> >install, next run of scons did not stop after the linking error, and
> >performed regular install of blender, with all deps, scripts, etc. Ofc no
> >blender and blenderplayer binary was there.
> >
> >regards
> >pio
> I tried to install libopenimage from the repo but the linking issue remains
> the same.
> Hope a dev can look into it,
> regards, Sam
> _______________________________________________
> Bf-committers mailing list
> Bf-committers at blender.org
> http://lists.blender.org/mailman/listinfo/bf-committers

More information about the Bf-committers mailing list