[Bf-committers] Scons building under Ubuntu broken

Sam samit_all at libero.it
Wed Sep 3 23:15:35 CEST 2014

>Same error here (Ubuntu 14.04 64bits).
>Anyway after that error you can do "make" and it will complete the
>compilation successfully. But yes, the scons one is broken (for me too
>at least).

in my case "make" after "scons" doesn't work.
it works if I compile with it from scratch, instead.

>Same here, Linux Mint 17, fresh system install:
>Linking program ==> 'blender'
>/usr/bin/ld: /home/piotao/blender-git/deps/oiio/lib/libOpenImageIO.so:
>undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
>/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libdl.so: error
>adding symbols: DSO missing from command line
>collect2: error: ld returned 1 exit status
>scons: *** [/home/piotao/blender-git/build/linux/bin/blender] Error 1
>scons: building terminated because of errors.
>Installing libopenimageio-dev from distro also did not help. But after this
>install, next run of scons did not stop after the linking error, and
>performed regular install of blender, with all deps, scripts, etc. Ofc no
>blender and blenderplayer binary was there.

I tried to install libopenimage from the repo but the linking issue remains
the same.
Hope a dev can look into it,

regards, Sam

More information about the Bf-committers mailing list