[Bf-committers] Building the latest trunk/master on Mac

Varanda - CG Labs cglabs at mail.com
Fri May 2 00:25:30 CEST 2014

Thanks Campbell… I agree. however, the yesterday’s trunk fails to build in my Mac laptop with both settings: OpenMP on and OpenMP off.
Now I am at home I can compare the settings between my Mac desktop with a build 2.69 which worked out-of-the-box with my laptop.
BTW… that was the build I used to generate the patch for the Vertice Randomization T38317 that you have provide some guidance :-)

The tweak in CMakeLists.txt was an attempt to follow Jens’s suggestions (along with the README).

Hopefully comparing my machines I may figure out what is going on as both have the same 10.9.2 OSX.

On May 1, 2014, at 5:54 PM, Campbell Barton <ideasman42 at gmail.com> wrote:

> @Varanda, setting WITH_OPENMP should disable OpenMP no matter what
> configuration you build on.
> From searching CMakeLists.txt files, I can't see anywhere that would
> enable this option, once disabled.
> On Fri, May 2, 2014 at 7:37 AM, Varanda - CG Labs <cglabs at mail.com> wrote:
>> Thanks Jens,
>> It is not clear yet to me: shouldn’t turning off WITH_OPENMP in ccmake makes the build happy ?
>> How can I override gcc in CMakeLists.txt to point to clang-imp? There is no visible ease line likes setting CC or CXX = ABC
>> The closest definition regarding to the compiler there is:
>>                        # Xcode 4 defaults to the Apple LLVM Compiler.
>>                        # Override the default compiler selection because Blender only compiles with gcc up to xcode 4.2
>>                        set(CMAKE_XCODE_ATTRIBUTE_GCC_VERSION "com.apple.compilers.llvmgcc42")
>>                        message(STATUS "Setting compiler to: " ${CMAKE_XCODE_ATTRIBUTE_GCC_VERSION})
>>                endif()
>> I am not familiar with cmake though. Some more digested information would be very welcome.
>> Thanks a lot,
>> Varanda
>> On May 1, 2014, at 4:28 PM, Jens Verwiebe <info at jensverwiebe.de> wrote:
>>> Use the clang-omp  i provided in libs. ( instructions in README ).
>>> Apple clang does not support openmp, but someone made it ON by default, which is not sufficient.
>>> Jens
>>> Am 01.05.2014 um 22:05 schrieb Varanda - CG Labs <cglabs at mail.com>:
>>>> Hello,
>>>> I am having problems to build Blender for MacOSX (Mavericks) using the very latest trunk/Master in my MacBook.
>>>> A couple months ago the entire process worked perfectly for my Mac desktop also with Mavericks.
>>>> The build complain about a missing lib: I guess libgompo, the logged error line is:
>>>> $ make
>>>> Scanning dependencies of target datatoc
>>>> [  0%] Building C object source/blender/datatoc/CMakeFiles/datatoc.dir/datatoc.c.o
>>>> clang: warning: argument unused during compilation: '-fopenmp'
>>>> Linking C executable ../../../bin/datatoc
>>>> ld: library not found for -lgomp
>>>> clang: error: linker command failed with exit code 1 (use -v to see invocation)
>>>> Disabling OpenMP on ccmake (WITH_OPENMP off) does not do any good.
>>>> Thanks in advance,
>>>> Varanda
>>>> _______________________________________________
>>>> Bf-committers mailing list
>>>> Bf-committers at blender.org
>>>> http://lists.blender.org/mailman/listinfo/bf-committers
>> _______________________________________________
>> Bf-committers mailing list
>> Bf-committers at blender.org
>> http://lists.blender.org/mailman/listinfo/bf-committers
> -- 
> - Campbell
> _______________________________________________
> Bf-committers mailing list
> Bf-committers at blender.org
> http://lists.blender.org/mailman/listinfo/bf-committers

More information about the Bf-committers mailing list