[Bf-committers] Missing: "/usr/include/python3.3m/Python.h"

Bastien Montagne montagne29 at wanadoo.fr
Wed Apr 23 16:27:49 CEST 2014

Just set CMake's PYTHON_VERSION to '3.4'...

On 23/04/2014 15:57, Nkansah Rexford wrote:
> I recently moved to ubuntu 14.04. I can't compile blender afterwards. It
> says the error message below
> CMake Error at CMakeLists.txt:2220 (message):
>    Missing: "/usr/include/python3.3m/Python.h",
>    Set the cache entry 'PYTHON_INCLUDE_DIR' to point to a valid python
> include
>    path.  Containing Python.h for python version "3.3"
> I went to see the /usr/include/ directory, and I only have these
> python-related folders: 2.7, 3.4 and 3.4m but no 3.3 or 3.3m
> I tried to install the python3.3 but got this message via apt-get:
> Package python3.3 is not available, but is referred to by another package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> However the following packages replace it:
>    python3.3-minimal libpython3.3-minimal libpython3.3
> E: Package 'python3.3' has no installation candidate
> I went on to try installing the packages listed, and it won't let me.
> Before my upgrade, compiling blender worked and didn't complain of
> anything. I'm also asking from Ubuntu community where that folder is gone
> to.
> Has blender moved to 3.4 yet? If not, any workaround for 14.04 users with
> no 3.3 include?
> thanks

More information about the Bf-committers mailing list