[Bf-committers] error on updating submodules

Dalai Felinto dfelinto at gmail.com
Tue Dec 24 12:57:41 CET 2013


I'm setting up a new computer and after getting the git repository I'm
failing to update the submodules:

$ git submodule update --init --recursive

Submodule 'release/datafiles/locale' () registered for path
Submodule 'release/scripts/addons' () registered for path
Submodule 'release/scripts/addons_contrib' () registered for path
Submodule 'scons' () registered for path 'scons'
fatal: Needed a single revision
Unable to find current revision in submodule path 'release/datafiles/locale'

I left the repository cloning happening over night, so I suspect
something may have gone wrong in the end. git fetch upstream (which is
BF) works fine too.

I even tried to re-setup the submodules but it didn't make any difference:

$ git config submodule.scons.url git://git.blender.org/scons.git
$ git config submodule.release/scripts/addons_contrib.url
$ git config submodule.release/scripts/addons.url
$ git config submodule.release/datafiles/locale.url
$ git submodule update --init --recursive

(same error as above, after the update command)

I'm on a Ubuntu 12.04 LTS, git

Any help is appreciated. Thanks,

More information about the Bf-committers mailing list