[Bf-committers] Bf-committers Digest, Vol 92, Issue 13

trouble daemon troubledaemon at gmail.com
Wed Mar 14 18:11:37 CET 2012

Ok, now for the actual replies! :)

> Sorry if I'm missing something, but switching the units to Imperial in the
> scene panel seems to do exactly what you ask.
> I don't use imperial units, but just tried if it works and I could easily
> scale the default cube to precise values entering "yd", "ft" or "in" after
> the numeric value and it worked (of course, after switching to imperial in
> the units section of the scene panel)

The main issue I had when trying to work with a blueprint, is that I
didn't like seeing yards at all, and entering "yd" only works when you
enter it in the panel in say, the dimensions section, of the
properties panel. But when you are trying to do something in edit mode
like "move this vertex 1-1/2inches to the left (x axis), then you are
only about to enter in metric or integer only values like "1.5".

Also, you can see now that I reposted the bounced email, that I was
considering another button specifically for architectural type work,
where something like yards is disabled by default, but is otherwise
mostly just imperial with display of fractions enabled as well.

And from Campbell:
> Regarding http://www.pasteall.org/30003
> Rather then adding "half-inch", "thirtysecond-inch"... etc, think it
> would be better to add a flag to "inch" that it can display as
> fractions.

Agree, but I just needed to fill something in for the time being :) I
think this also covers the fact that sometimes, blender will show

1.5-1/2" instead of 1-1/4", so something needs to be done in the
parser to tell blender to reduce those fractions down better. I just
don't know how myself.

> This is some more work but avoids adding cruft.
> The other thing that is tricky is how to correctly parse this back as
> input, since the buttons can take arithmetic as input, mixed with
> dimensions...
> "-1/4\""
> would currently translate to...
> -1/4*0.0254
> Its possible that imperial unit display cant be easily parsed (or it
> might have to have a custom parser written)
> this may be harder to solve if we are to keep
> button-display-as-button-input working.

I definetly like the idea of being able to toggle the units, but I
don't know the py menu stuff well enough to even consider adding such
checkboxes, sorry.

As for the aritmetic, I realize it is a problem, but it seems that the
parser works to some degree when it sees something like 1-1/2", for
example. I also noticed in the code that it accepts commas as well, so
perhaps thats a better way. Although, if the artimetic parser could be
changed to only do actual math when there is a space, I think it would
work fine too.

From: Knapp <magick.crow at gmail.com>
> I know that people used to imperial units have a hard time with metric
> but I really think that people need to change to metric and forcing
> Blender to work with all these strange units is a big waste of time.
> BTW I come from the USA. Being able to enter units in imperial units
> is nice but why not just let the readout be in normal units. I mean
> 1/4 and inch is ok but so is .25 and in a lot of ways it is way easier
> to think in the second way. As an American I think having units like 2
> feet 6.25 inches is just fine.

Sure, being able to enter .25 should auto translate to 1/4", but when
you do something like enter blueprints or floor plans or something, it
is nice to see units displayed as you entered them or as they appear
on your plans, rather than some metric units or fractions. Otherwise,
you have to keep doing mental math as you compare your work on screen
to the plans for the sake of double checking your work.

Anyways, sorry for the long post and repost, and thanks for the replies!

More information about the Bf-committers mailing list