[Bf-committers] Fedora 17 updated to OpenImageIO version 1.0.5 No longer links Blender

Terry Wallwork terrywallwork at netscape.net
Thu Jun 28 15:42:15 CEST 2012

Hi Richard,

Yes I am building Blender with Cmake, and yes I build Blender frequently 
to keep up to date with its progress, I never use the Fedora provided 
sources only ever Blender Trunk SVN. The older version of OIIO worked ok 
(before the Fedora rpm update).  I am not building my own version of 
OIIO from source am purely using the Fedora RPM binaries to give me that.

This is probably just as case of Blender not catching up with OIIO yet, 
so I posted just in case :)

I will likely build an older version of OIIO to get Blender linking 
again and then wait for Blender to catch up (assuming that this is 
Blender's fault and not mine or OIIO)

Terry Wallwork

On 06/28/2012 01:58 PM, Richard Shaw wrote:
> On Thu, Jun 28, 2012 at 6:52 AM, Terry Wallwork
> <terrywallwork at netscape.net> wrote:
>> Hi,
>> Just tried building the latest svn version of Blender and it will no
>> longer link since Fedora updated to OpenImageIo Version 1.0.5
> I'm assuming you're building with Cmake? That what the snippet you
> posted looked like but admittedly I haven't build blender with scons
> for so long that I wouldn't know what it "looks" like.
> I'm the OpenImageIO maintainer for Fedora and co-maintainer of
> blender. I assume you're building your own package to ether keep more
> up to date or to enable features that are disabled in Fedora?
> Are you building blender directly yourself? Or are you using a source RPM?
> I use the following cmake options in my spec file for cycles/oiio:
>        -DCYCLES_OIIO:PATH=%{_prefix} \
>        -DOPENIMAGEIO_INCLUDES:PATH=%{_includedir}/OpenImageIO \
> Richard
> _______________________________________________
> Bf-committers mailing list
> Bf-committers at blender.org
> http://lists.blender.org/mailman/listinfo/bf-committers

More information about the Bf-committers mailing list