[Bf-committers] RPATH issue with blender binary

Campbell Barton ideasman42 at gmail.com
Thu Aug 4 06:19:09 CEST 2011

>From looking into this RPM is checking for RPATH's with readelf.

I tried this on fedora and arch linux blender builds.
readelf -d ./blender.bin  | grep "RPATH"

And only got this on arch (nothing on fedora with both scons and cmake)

/dsk/data/src/blender/blender> readelf -d ./blender.bin  | grep "RPATH"
 0x000000000000000f (RPATH)              Library rpath:

Guessing this is specific to you you're building.

On Thu, Aug 4, 2011 at 10:59 AM, Richard Shaw <hobbes1069 at gmail.com> wrote:
> I ran across this before but have now forgotten how I fixed/worked around it.
> ERROR   0002: file '/usr/bin/blender' contains an invalid rpath
> '/usr/include/lib' in
> [/usr/include/lib:/home/build/rpmbuild/blender/BUILD/blender-2.58/Build/lib]
> ERROR   0002: file '/usr/bin/blender' contains an invalid rpath
> '/home/build/rpmbuild/blender/BUILD/blender-2.58/Build/lib' in
> [/usr/include/lib:/home/build/rpmbuild/blender/BUILD/blender-2.58/Build/lib]
> error: Bad exit status from /var/tmp/rpm-tmp.OyE2yG (%install)
> I tried grepping through all the CMakeLists.txt files but nothing
> jumped out at me. Got any ideas on where to start looking?
> Thanks,
> Richard
> _______________________________________________
> Bf-committers mailing list
> Bf-committers at blender.org
> http://lists.blender.org/mailman/listinfo/bf-committers

- Campbell

More information about the Bf-committers mailing list