[Bf-committers] Blender-2.55 has no menu bar

Dave Plater dplater at webafrica.org.za
Thu Nov 4 01:09:51 CET 2010

On 11/04/2010 12:33 AM, Campbell Barton wrote:
> On Wed, Nov 3, 2010 at 1:09 PM, Dave Plater <dplater at webafrica.org.za> wrote:
>> On 11/02/2010 11:02 PM, Dan Eicher wrote:
>>> Been seeing some weirdness on recent builds on Ubuntu 10.10 x86_32.
>>> The menu bar doesn't show up like the OP and if I try to resize a window
>>> (mouse over the border until the double arrows show up) as soon as I start
>>> to move it the top header jumps to the mouse position.
>>> If I open older .blend files everything works as expected.
>>> 99% sure r32757 is the cause, reverting that and everything works fine.
>>> Dan
>> Thanks, I'm building 2.54, which I never finished due to windowmanager
>> not finding BPY_extern.h. Busy tying to add the neccesary -I flag,
>> couldn't add it via $CFLAGS so I'll have to patch the relevant
>> CMakeLists.txt. If I have a sucessful 2.54 build I can work forwards to
>> find the problem. Also fighting with kdevelop3 which freezes when I load
>> blender project.
>> Dave P
> Undid most changes from r32757, Can you test r32861? Dan says its
> working now, not sure why this worked for me but broke elsewhere.
It built and published at lightening speed but it still doesn't have a
menu. If you have the time, please look at the spec file at :
or if that url doesn't work it's got a rather long revision code at the
end :
and navigate to "Source Files" where you'll find the "blender.spec"
link. You might spot something in the %build or %install section.
Dave P

More information about the Bf-committers mailing list