[Bf-committers] Blender-2.55 has no menu bar

Campbell Barton ideasman42 at gmail.com
Mon Nov 1 00:52:20 CET 2010

You shouldn't need to copy files from /usr/share/blender into
~/.blender, if so then its a bug.

I just tested and it work as expected.

With CMake, set the CMAKE_INSTALL_PREFIX variable, its "/usr/local" by
default, I set it to "/opt/blender25"

"make install" copies the files into the install prefix.

For an example on using CMake to create a package see:

You could look into why it cant find the script directory using strace.

If you grep for the dir you filter out a lot of junk, notice the last
line the path is found, eg:

 ~ # strace /opt/blender25/bin/blender 2>&1 | grep "/opt/blender25"
execve("/opt/blender25/bin/blender", ["/opt/blender25/bin/blender"],
[/* 36 vars */]) = 0
readlink("/proc/self/exe", "/opt/blender25/bin/blender", 4094) = 26
stat("/opt/blender25/bin/blender", {st_mode=S_IFREG|0755,
st_size=125951465, ...}) = 0
stat("/opt/blender25/bin/2.55/config", 0x7fff8291a6e0) = -1 ENOENT (No
such file or directory)
stat("/opt/blender25/bin/2.55/config", 0x7fff8291a6a0) = -1 ENOENT (No
such file or directory)
stat("/opt/blender25/bin/2.55/python", 0x7fff8291a770) = -1 ENOENT (No
such file or directory)
stat("/opt/blender25/bin/release/python", 0x7fff8291a580) = -1 ENOENT
(No such file or directory)
stat("/opt/blender25/share/blender/2.55/python", 0x7fff8291a580) = -1
ENOENT (No such file or directory)
readlink("/opt/blender25/bin/blender", 0x7fff82905940, 4096) = -1
EINVAL (Invalid argument)
stat("/opt/blender25/bin/Modules/Setup", 0x7fff82906880) = -1 ENOENT
(No such file or directory)
{st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0

On Sun, Oct 31, 2010 at 10:56 PM, Dave Plater <dplater at webafrica.org.za> wrote:
> On 10/31/2010 08:29 PM, blendenzo wrote:
>> Oh, sorry.  I guess this is related to ~/.blender, since the 2.54 and
>> 2.55 folders do end up in ~/.blender.  Would it be helpful for you to
>> see a directory tree of my ~/.blender folder on Linux Mint?
>> On 10/31/2010 02:25 PM, blendenzo wrote:
>>> Hi Dave,
>>> I experienced a very similar error on Linux Mint, and it was not related
>>> to the ~/.blender folder.  When the versioning changed from 2.54 to
>>> 2.55, cmake was not properly updating the scripts folders.
>>> Specifically, the folder /blender/2.54 should now be /blender/2.55,
>>> since Blender is now looking for the UI scripts in the 2.55 folder.  I
>>> deleted the /blender/2.54 folder, but cmake did not replace it.  In the
>>> end, I had to delete the entire build and build from scratch and this
>>> solved the problem.
>>> Are you building fresh or building on top of a previous 2.54 build?  If
>>> you are building on a previous build, I think this could be what is
>>> causing the problem.
>>> Regards,
>>> Tony
>>> On 10/30/2010 09:56 AM, Dave Plater wrote:
>>>> Hi, I've opened Blender 2.5 Bug Tracker item #24454 for the lack of menu
>>>> bar when I run blender. I built it with the following configuration :
>>>> cmake ../ -DWITH_FFTW3:BOOL=on -DWITH_JACK:BOOL=on
>>>> -DOPENCOLLADA_LIBPATH=/usr/lib64 -DOPENCOLLADA_INC=/usr/include
>>>> -DWITH_CXX_GUARDEDALLOC:BOOL=off '-DPYTHON_LIB=/usr/lib64}/libpython3.1.so'
>>>>    -DPYTHON_INC=/usr/include/python3.1 '-GUnix Makefiles'
>>>> In the past this has been caused by the contents of ~/.blender but this
>>>> time I've tried various things including using the .blender contents from :
>>>> blender-2.54-beta-linux-glibc27-x86_64.tar.bz2
>>>> and I still have no menu bar.
>>>> Can somebody please give me a clue where to look, especially what
>>>> blender expects to find in .blender.
>>>> Thanks
>>>> Dave Plater
>>>> _______________________________________________
> I've come to the conclusion that the /usr/share/blender/2.55 folder has
> to be copied to ~/.blender but I've still got no menus. This is a clean
> chrooted rpmbuild build and I've deleted and recreated .blender many
> times. A view of your ~/.blender directory tree would be much appreciated.
> Regards
> Dave P
> _______________________________________________
> Bf-committers mailing list
> Bf-committers at blender.org
> http://lists.blender.org/mailman/listinfo/bf-committers

- Campbell

More information about the Bf-committers mailing list