[Bf-committers] RNA Rename Proposal
dfelinto at gmail.com
Mon Aug 16 21:42:00 CEST 2010
regarding Sensors, Controllers and Actuators.
1) Controller.state -> states - a Controller can only have one state,
therefore I think it's better if we stick with the singular, no?
2) Must of the the renaming is fine, however in some cases the boolean
rename looks a bit odd for me. Whenever we have a verb in the RNA prop name
the use of "use" sounds strange to me. English is not my first language, and
I know that API doesn't have to "make sense". Nevertheless those are some of
the examples I'm thinking of:
Actuator|EditObjectActuator.replace_physics_mesh -> use_replace_physics_mesh
Actuator|ConstraintActuator.force_distance -> use_force_distance
Actuator|ConstraintActuator.persistent -> use_persistent
Controller.priority -> use_priority
I think it makes sense if we are talking: "use priority [option]", "use
force distance [option]". If so then I think it's fine. Otherwise I would
suggest something like: "force persistence", "force priority", ...
Anyways, my 2 cents.
2010/8/16 Campbell Barton <ideasman42 at gmail.com>
> Here is a list of RNA properties to rename edited by Brecht, Luca and
> myself (as mentioned last meeting).
> The lines which are colored have been changed from there original
> values, sorted by Class/attr.
> Of 4605 names 1471 have changed, I'll need to write up some docs so
> theres better guidelines for naming new RNA properties based on the
> changes made here.
> Tomorrow I'll start to go ahead and apply the naming changes for
> UserPrefs, Themes and SpaceTypes since they are unlikely to be
> controversial or break peoples scripts.
> In the meantime any developers who added RNA into blender could look
> at this list and make sure the names are ok.
> - Campbell
> Bf-committers mailing list
> Bf-committers at blender.org
More information about the Bf-committers