[Bf-committers] minimum required cmake version ?

Alexander Neundorf neundorf at kde.org
Sat Jun 27 15:44:24 CEST 2009


currently when building blender with cmake, at least version 2.4.0 of cmake is 
The current released version of cmake is 2.6.4.

I would suggest to require at least version 2.4.5 of cmake. A lot of bug fixes 
(compared to 2.4.0) went into it, and also some features. 
CMake 2.4.5 is the version of cmake which was required by KDE 4.0 and 4.1. KDE 
4.0 was released early 2008, so by now basically all Linux distributions ship 
at least this version of cmake.

But actually I would recommend to require cmake 2.6.3. Release 2.6 brought a 
lot of improvements and new features (from simple ones like more 
Find-modules, functions additionally to macros, cross compiling, much more). 
KDE 4.2, released January this year, requires this version, so most/many 
current Linux distributions should have this version now (but maybe not as 
much as 2.4.5).

What do you think ?


More information about the Bf-committers mailing list