[Bf-committers] Blender GUI not working anymore on Debian sid.

Dietrich Bollmann diresu at web.de
Thu Aug 27 18:27:39 CEST 2009

Hi Joe, Campbell and Julien :)

Thank you very much for your answers.

I answer to all three messages in one mail in order to reduce the number
of mails on the mailing list...

On Thu, 2009-08-27 at 08:10 -0600, joe wrote:
> Sounds like something changed or went wrong with your graphics
> drivers.  What graphics card do you have?
> Joe

Hi Joe, 

Here is what 'lspci' tells me:

  00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME,   
  943/940GML Express Integrated Graphics Controller (rev 03)

Until now I never had any problems - and currently only the blender
menus seem to make problems.

On Thu, 2009-08-27 at 07:41 -0700, Campbell Barton wrote:
if you download blender from blender.org it comes with an option to
> run with Mesa (softeare opengl)
> - try running "blender-softwaregl"

Hi Campbell.  Thanks!  

I downloaded the blender.org distribution and it worked when starting
blender with "blender-softwaregl" :)

As I rely on a customized version of blender, I than manipulated the
"blender-softwaregl" script to start my own compiled blender version -
and it works also :)

Looking at the script I suppose that it works because it uses the
libGL.so and libGLU.so libraries provided by the blender.org blender
distribution?  These probably are the Mesa libs you mentioned?  Until
now I thought Debian is using mesa also, so this is not the case?  Or,
if it is, do you know about the differences between the versions
installed by Debian and the versions you are providing?

Do you think it is a "good" solution for my problem to start blender
from now on using the wrapper script provided by the blender.org blender

Sorry for asking you all these things, I am curious :)

On Thu, 2009-08-27 at 17:04 +0200, revuedelibre . wrote:
> Hello,
> I had the same problem with my debian sid. I updated my nvidia drivers ( non
> free ), and it works well now. Before my update, only Blender was not
> running, others "classical" programs worked well  (iceweasel, openoffice,
> gimp ... )

Hi Julien,

I don't use an external graphics card as I have a (very small) laptop
with an onboard graphics chipset.

But gimp, iceweasel and openoffice seem to work without problems here
also.  Only Blender's menus don't show up when not using the wrapper
script provided by the blender download from blender.org.  Do you have
any idea how to update my drivers if not from the debian sid packages?
And could this help to start blender without using the wrapper script?

Thank you all for your help!

Regards, Dietrich

By the way, I first asked on the debian-user mailing list.

I got one answer indicating me the following posting:

> Its a wonder it works as well as it does:

Probably you know about this mail already, but I thought I just mention
it for any case... 

> Regards,
> Julien

More information about the Bf-committers mailing list