[Bf-committers] compiling 32 bit blender on 64 bit linux

malefico andauer the3d_hut at yahoo.com.ar
Wed May 31 22:10:14 CEST 2006

Alfredo, I have been able to compile 32bit blender
under ubuntu linux in 64bits.

What I did was install "dchroot". This installs 32bit
version of almost all needed libraries and software to
compile blender.

After that, using scons as usual (opening a terminal
using "dchroot -d" and then "scons") works.

Best regards


 --- Alfredo de Greef <eeshlo at yahoo.com> escribió:

> Hi everyone,
> Up to a month ago I compiled Blender without any
> apparent problems on 64 bit linux, without any
> modification. However, now having to work again on
> the
> yafray code, I'm experiencing problems. For some
> reason, pre-242 (cvs) blendfiles load incorrectly,
> specifically, the RenderData struct seems to contain
> incorrect, or at least 'shifted' values. What I mean
> with 'shifted' is that parameters do have the
> correct
> values, but from *other* parameters, values are not
> assigned to the correct parameter.
> Anyway, I don't know why everything worked before,
> something apparently recently changed, but this
> might
> have something to do with Blender's known 64 bit
> problems.
> So I would like to know how to compile a 32 bit
> version of Blender on 64 bit Linux. I use SuSe 10.0,
> with gcc 4.0.2 and scons. I'm no expert when it
> comes
> to these things, I can only guess what I'm supposed
> to
> do. I have tried adding the '-m32' flag to
> CFLAGS/CCFLAGS & CXXFLAGS in the user-config.py
> file,
> but apparently this is not enough, it seems to work
> fine until 'makesdna.c', at which point it stops:
> warning: i386 architecture of input file
> is incompatible with i386:x86-64 output
> warning: i386 architecture of input file
> `intern/guardedalloc/intern/mallocn.o' is
> incompatible
> with i386:x86-64 output
> ../build/linux2/makesdna
> scons: ***
> Error -11
> scons: building terminated because of errors.
> I have tried several random things, at one point I
> got
> past this point, but then either makesdna segfaults
> or
> the linking stage is still trying to link with the
> 64
> bit libraries. But can't remember how I accomplished
> either.
> Searching for info on the net, I found similar
> stories
> of problems on compiling 32 bit programs on 64 bit
> linux (for the SuSe distro at least), sometimes
> without a solution, so maybe this is not something
> unusual.
> So my question is, can anyone give me a step by step
> description of the required changes to get a 32 bit
> version of Blender? I'm willing to try the makefile
> system as well.
> Thanks in advance!
> Alfredo
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam
> protection around 
> http://mail.yahoo.com 
> _______________________________________________
> Bf-committers mailing list
> Bf-committers at projects.blender.org

1GB gratis, Antivirus y Antispam 
Correo Yahoo!, el mejor correo web del mundo 

More information about the Bf-committers mailing list