[Bf-committers] Vector blur not working?

Mats Holmberg mats.holmberg at elisanet.fi
Sun Feb 26 15:45:46 CET 2006

Fabrizio wrote:

>You're all still missing the problem with Mats original file (quoted
>below)!! :o/
>1. Open his original 'test1'  file in cvs blender
>2. add a cube.
>3. parent it to the armature
>4. render.
>The cube has vector blur without the need to touch any of his node or render
>settings. The dog doesn't have any motion blur.
>This has nothing to do with setting a composite node (which is already
>there), touching the min/max buttons, or number of vertices changing per
>frame as reported in the console. Objects created in cvs blender work fine.
>Objects from a file created in official builds don't.
>If you link the speed output to a viewer node you will see there is no data
>for the dog mesh. Nor do any of these solutions explain the problems with
>overexposed AO or weird zbuf data or not being able to shiftF1 append
>anything from Mats file...
>ps. Nathan. Did you create the sphere and animation in 2.41 before loading
>in cvs blender? That is when the problem should occur.

I did some digging and at 
I found this:

    vector blur

 Orange-reported vectorblur bug: when using autosmooth, the amount of
 vertices differed on previous/next frame, causing speedvector calculus
 to be skipped.
 Now that worked OK, where it not that non-existing speed vectors were not
 initialized zero while rendering...
 Also another issue showed up with autosmooth. When using exact smooth
 angles (like 30 degrees) on a model that has been spinned with exactly
 30 degree steps, the autosmooth gave different results on each frame...
 and only when compiled in O2 (probably thats doing bad float rounding).
 Solved this by just adding 0.1 to the user defined smooth angle.

Well this seems to be a bug reported, and solved... at least it should 
be! But, I tried my testfile again, unchecked Autosmooth, and voilá... I 
got vectorblur. So this is a bug still.


More information about the Bf-committers mailing list