[Bf-committers] (no subject)

jlp at nerim.net jlp at nerim.net
Mon Aug 8 17:21:30 CEST 2005

This leaves us with two options:
1) Do not use scons 0.96.90, downgrade to the next version down.  0.96.1 does
not contain this problem.  However, everyone wanting to build blender would
need to know this.  If anyone can figure out a good cross-platform way to
detect the version of scons running and print big warning that's a way of
2) Implement a dirty hack to create the directory if it isn't there, a bit of
kludgy python could take care of this if needed, but do we want to hack
scons or should we wait until they fix it?

I think I've got a decent way to hack around it, but I wasn't sure if we
wanted to put dirty code into the SConstruct file over a version-specific
It wouldn't be a problem really except it happens to be the latest version.
Should the workaround be put in and taken out later or should we all just
this version and try and make sure everyone else does too?

I fear it is the other way around. Iow, we are wrong and the scons guys
are right.

what fails it trying to access a sconsign file in a non existant (yet)
directory. this is clearly an error. That it worked in the past (and
created the dir) dont make it better.

In fact there is already is sconstruct code a workaround for exactly the
same problem at the upper level

0.96.90 was released in February, and blender worked with it. it was
broken for a month or so. We certainly made a change in our part that
provoked that

More, scons 0.97 is meant to clean existing kludges. So we should adapt

More information about the Bf-committers mailing list