[Bf-committers] RE: OOPS-Outliner crash

Meino Christian Cramer Meino.Cramer at gmx.de
Thu Oct 7 07:38:12 CEST 2004

Uuuuhh....SORRY for the wrong alert previously!

 The problem is not blender (or not fully...) : The key sequence is
 bind to "Minimize windows" on my Window Manager (the crash from
 inside gdb remains, though...). This simulates a crash nearly
 perfectly, when not awaited.... ;)

 But this brings up another problem:
 As long as Blender does not support to remap Key Bindings in some way
 (user prefs, config file or something similiar), one is urged to
 install and to get used to another window manager, if this window
 manager does also not support key remapping (as blender...) only for
 being able to use blender and its hotkeys....(the view menu does not
 show any apprpiate entry and many hotkeys does not have any menu
 entry at all...)

 Furthermore "hotkey clashes" with other programs are possible, if the
 user is no longer able to rearrange hotkeys in a way, that no
 overlapping occurs.

 And this scenario becomes more and more evident, the more
 functionality -- and therefore hotkeys -- are added to blender, which
 itself is in turn a very nice thing! ;)

 Keep hacking!



> Hi,
>  I read the description of the new outline mode on www.blender3d.org.
>  With an "empty" blender ("nothing" in the scene) and nothing selected
>  to be shown in the oops-Window Blender crashes at once, when pressing 
>  SHFT-ALT-F9 (I cannot find anything appropiate in the VIEW-menu.
>  I tried a simply scene (plane,camera,light) but blender still crashes
>  with SHFT-ALT-F9.
>  I tried to start blender from gdb to check, what is going on, but gdb
>  seems not to like blender very much (or vice versa):
>   [~/] :gdb /usr/local/bin/blender
>   GNU gdb 6.2
>   Copyright 2004 Free Software Foundation, Inc.
>   GDB is free software, covered by the GNU General Public License, and you are
>   welcome to change it and/or distribute copies of it under certain conditions.
>   Type "show copying" to see the conditions.
>   There is absolutely no warranty for GDB.  Type "show warranty" for details.
>   This GDB was configured as "i686-pc-linux-gnu"...Using host libthread_db library "/lib/libthread_db.so.1".
>   (gdb) run
>   Starting program: /usr/local/bin/blender 
>   [Thread debugging using libthread_db enabled]
>   [New Thread 16384 (LWP 25423)]
>   Checking for Python install...
>   Installed Python found!
>   Program received signal SIGFPE, Arithmetic exception.
>   [Switching to Thread 16384 (LWP 25423)]
>   0xb78dc3c0 in _mesa_test_os_sse_exception_support ()
>      from /usr/X11R6/lib/modules/dri/radeon_dri.so
>   (gdb) 
>  This happens without haveing seen the blender window at all....(no
>  user interaction is needed to crash blender from within gdb)
>  My CVS snapshot is of "Oct  7 03:24"....
>  Keep hacking!
>  Meino

More information about the Bf-committers mailing list