Patch: Re: [Bf-committers] SCons on OS X

Christian Plessl
Wed, 10 Mar 2004 22:59:20 +0100

Indeed, the error you're expericencing is very strange, for me  
everything works perfectly. I have attached the corresponding gcc call  
that failed for you (because of bogous double quotes). In my build  
environment everything works as expected.

On 10.03.2004, at 16:33 Uhr, Douglas Bischoff wrote:

> On Mar 9, 2004, at 4:27 PM, Christian Plessl wrote:
>>> The patch submitted doesn't seem to get around the issue of missing  
>>> files. One oddity that I noticed is that the system library root was  
>>> specified to be INSIDE the OpenGL library... this seemed odd.
>> What files are missing? I don't have missing files.
> Here is the exact error. Note the quotes around the "framework" calls  
> at the beginning.
> ----
> gcc " -framework Carbon" " -framework AGL" " -framework Python" "  
> -framework QuickTime" -o blender  
> /Volumes/DBG4Data/Users/developer/Projects/build/darwin/source/ 
> creator/d_buildinfo.o  
> -L/Volumes/DBG4Data/Users/developer/Projects/build/darwin/lib -Llib  
> -L/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ 
> python2.3/config  
> -L/Volumes/DBG4Data/Users/developer/Projects/blenderlib/darwin-7.2.0- 
> powerpc/sdl/lib  
> -L/System/Library/Frameworks/OpenGL.framework/Libraries -L/sw/lib  
> -lblender_creator -lblender_render -lblender_yafray  
> -lblender_blendersrc -lblender_renderconverter -lblender_blenloader  
> -lblender_writestreamglue -lblender_deflate -lblender_writeblenfile  
> -lblender_readblenfile -lblender_readstreamglue -lblender_inflate  
> -lblender_img -lblender_radiosity -lblender_blenkernel  
> -lblender_blenpluginapi -lblender_imbuf -lblender_avi  
> -lblender_blenlib -lblender_python -lblender_makesdna -lblender_kernel  
> -lblender_BSP -lblender_LOD -lblender_GHOST -lblender_STR  
> -lblender_guardedalloc -lblender_BMF -lblender_CTR -lblender_MEM  
> -lblender_IK -lblender_MT -lsoundsystem -lblender_quicktime -lSDL  
> -lpng -ljpeg -lz -lstdc++ -lobjc -lGL -lGLU
> gcc:  -framework Carbon: No such file or directory
> gcc:  -framework AGL: No such file or directory
> gcc:  -framework Python: No such file or directory
> gcc:  -framework QuickTime: No such file or directory
> scons: *** [blender] Error 1
> ----

gcc -framework Carbon -framework AGL -framework Python -framework  
QuickTime -o blender  
-L/Users/plessl/Documents/blender_cvs/build/lib -Llib  
-L/System/Library/Frameworks/OpenGL.framework/Libraries -L/sw/lib  
-lblender_creator -lblender_render -lblender_yafray  
-lblender_blendersrc -lblender_renderconverter -lblender_blenloader  
-lblender_writestreamglue -lblender_deflate -lblender_writeblenfile  
-lblender_readblenfile -lblender_readstreamglue -lblender_inflate  
-lblender_img -lblender_radiosity -lblender_blenkernel  
-lblender_blenpluginapi -lblender_imbuf -lblender_avi -lblender_blenlib  
-lblender_python -lblender_makesdna -lblender_kernel -lblender_BSP  
-lblender_LOD -lblender_GHOST -lblender_STR -lblender_guardedalloc  
-lblender_BMF -lblender_CTR -lblender_MEM -lblender_IK -lblender_MT  
-lsoundsystem -lblender_quicktime -lSDL -lpng -ljpeg -lz -lstdc++  
-lobjc -lGL -lGLU

Seems pretty similar to what you have, besides the double quotes around  
the -framework calls. I have no idea, what the cause for this different  
behavior could be.

What shell are you using, maybe this could make a difference? I'm using  
bash, but I also tried building with tcsh, which also worked fine.

What scons version do use use? --help brings reports on my  

192:~/Documents/blender_cvs/blender plessl$ ./ -v
SCons by Steven Knight et al.:
         script: v0.94.D001, 2003/11/07 06:02:01, by knight on casablanca
         engine: v0.94.D001, 2003/11/07 06:02:01, by knight on casablanca
Copyright (c) 2001, 2002, 2003 Steven Knight

> Still no luck with the patch. I have added -lobjc to SConstruct, but  
> at the moment it seems moot because of the problems with -frameworks  
> in quotes. Also, I notice it is attempting to link to -Llib.... this  
> doesn't seem like a real link to me, and when I try to hand-type the  
> command above without the quotes it complains that there is no library  
> called "lib".

Option -Llib tells the linker, to search the directory lib for  
libraries during the linking process. I guess this information is  
derived from the platform_libpath, which I have set to:

platform_libpath =  
['/System/Library/Frameworks/OpenGL.framework/Libraries', '/sw/lib']

Do you have 'lib' in your platform_libpath? This could explain -Llib