[Bf-committers] OS X 10.3.2 SCons, redux part 2

Matt Ebb bf-committers@blender.org
Thu, 8 Jan 2004 13:15:29 +1100

Here's an update to my situation, for reference. Sgefant gave me some  
help in IRC last night, and I got a bit further. Appending 'objc' to my  
platform_libs got rid of my last problem (ld: /usr/lib/crt1.o illegal  
reference to symbol: __objcInit defined in indirectly referenced  
dynamic library /usr/lib/libobjc.A.dylib) and Blender finally got  

Sgefant then tried helping me to get Python working properly (without  
manually typing in paths)by adding (I think it was just this line?)

     link_env.Append (LINKFLAGS=' -framework Python')

to line 305. This didn't seem to work properly and it looked like it  
actually broke SCons itself, rather than the build:

scons: *** unable to fetch contents of '<SCons.Executor.Executor  
instance at 0x6aaa08>'
scons: internal stack trace:
SCons/Taskmaster.py", line 349, in next_task
SCons/Taskmaster.py", line 168, in make_ready
if not t.current(c):
SCons/Node/FS.py", line 1457, in current
bsig = calc.bsig(self)
SCons/Sig/__init__.py", line 372, in bsig
SCons/Sig/MD5.py", line 84, in signature
raise AttributeError, "unable to fetch contents of '%s'" % str(obj)
scons: building terminated because of errors.

Anyway, I went back to the original setup I had with the python  
variables written in manually to point to /sw/

Next, tried to build with QuickTime. I copied:

if use_quicktime == 'true':
         defines += ['WITH_QUICKTIME']

to the Darwin section, which I found in sgefant's SConstruct. I did a  
scons --clean, and then rebuilt - libblender_quicktime.a gets compiled  
correctly and it seems to link as well. However, QuickTime in Blender  
doesn't work! :( There is no Quicktime option in the file format menu,  
and I can't import QuickTime movies.

Ignoring that for now and moving along, I tried to build with  
international fonts. I added this to the darwin section (half copied  
from linux2):

     # International stuff
     if (use_international == 'true'):
         defines += ['INTERNATIONAL', 'FTGL_STATIC_LIBRARY',  
         platform_libpath += [darwin_precomp + '/ftgl/lib']
         platform_libs += ['ftgl', 'freetype']
         extra_includes += [darwin_precomp + '/ftgl/include',

FTF_TTFont.cpp couldn't find BKE_utildefines.h so I appended  
'../blenkernel' to the end of include_paths in  

Trying to build with these settings then gives the error:

ld: Undefined symbols:
scons: *** [blender] Error 1
scons: building terminated because of errors.

And that's what I'm up to now.

Sorry for the huge mail again - I'm really just experimenting with  
trial and error, so I thought as much info as possible would be helpful  
to try and sort this out.