[Bf-committers] More SCons on OS X

Stefan Gartner bf-committers@blender.org
Thu, 1 Apr 2004 19:35:41 +0200

I had the same error on linux using the Makefiles after switching from python 
2.3 to python 2.2. A clean build (or rather removing all python related *.o 
files from the build directory) fixed it.


On Thursday 01 April 2004 19:25, Douglas Bischoff wrote:
> Greetings again:
> After several successful compiles on OS X using SCons, something has
> broken. Not sure what changed, but this is what I'm getting:
> ld: Undefined symbols:
> _PyCFunction_NewEx
> This is happening during the final linking stage. I couldn't find any
> function in Blender's source tree that referenced or defined
> PyCFunction_NewEx, so I'm a bit baffled.
> One possibility is that instead of linking with -lPython I'm using
> -framework Python to link against the system Python framework.
> Any ideas?
> -Bischofftep
> _______________________________________________
> Bf-committers mailing list
> Bf-committers@blender.org
> http://www.blender.org/mailman/listinfo/bf-committers