[Bf-committers] Using GameObject IDs when calling from Python,
or changing names of added objects?
Mon, 15 Sep 2003 09:52:21 -0700
> The itch is that (e.g.) the trackTo actuator can currently take only
> the name of the object as a parameter, and for objects added with the
> addObject actuator that is a problem 'cause they all have the same name..
The most obvious thing to me would instead of a setName actuator, to
automatically keep names unique the same way they are in blender
normally. If that name exists already, incremement the end by .001.
I'm not sure how possible this is with added objects, if they aren't
"true" blender objects that could make things a bit more difficult. But
if we could find the naming functions could it be possible to hijack
them and "apply" them onto added objects, at least when it comes to the
I think thought that this problem is best solved by trying to fix it at
the root rather than trying to find a workaround. Good luck with it,
I'll look at the source some and see if I can be of any help.