[Bf-committers] Re: Compiling blender on OS X 10.3

Michael Velikanje bf-committers@blender.org
Tue, 28 Oct 2003 20:52:44 -0900

Ok I lied, setting -mcpu=G4 -fast does work for compiling 
QUICKTIME=true on 10.3 the same as it did on 10.2. But it only works if 
you add it to the nan_compile.mk file that is in the dir that you are 
actually compiling in.Not like I tried, editing the nan_compile.mk file 
in an archived dir.
ifeq ($(OS),darwin)
     CC	= gcc
     CCC	= g++
     CFLAGS	+= -pipe -fPIC -mcpu=G4 -fast
     CCFLAGS	+= -pipe -fPIC -mcpu=G4 -fast
Every thing that I've tried works great :^)

Michael Velikanje

On Oct 27, 2003, at 10:03 PM, Michael Velikanje wrote:

> I updated to 10.3, very nice! I did an archive the old system and 
> install 10.3 clean. Some of the files available on 10.2 are missing 
> (this may not be a problem if doing an upgrade), such as stats.h in 
> the Kernel.framework. It ships with Python2.3 as a Framework, 
> libpython2.3.a is missing so compiling python is necessary for the lib 
> and to use python with blender, math.py is missing from 
> Python.framework but is there if you compile and install to 
> /usr/local/lib, good news is that python compiles with the new xtools 
> using configure make with out any fuss.
> When I tried gcc3.3 on 10.2 setting the -fast -mcpu=G4 flags fixed the 
> DNA_id.h and AIFF.h conflict over ID, no such luck on 10.3, setting 
> QUICKTIME=false works though, blender compiles and runs great, thats 
> more important than QT support, for now anyway ;)
> It took me several hours to get blender to compile on 10.3 but most of 
> that was waiting to see where it was going to fail in the compile 
> rather than fixing the problem. Upgrading was worth the cost of 10.3 
> and the little time spent in getting blender to compile, the only 
> serious problem (most likely not for a good programer;) is the 
> conflict in DNA_id.h and AIFF.h over ID when compiling with 
> :^) Happy camper :^)
> Michael Velikanje