[Bf-committers] Re: Themes, vertex size

Michael Velikanje bf-committers@blender.org
Sun, 07 Dec 2003 12:32:31 -0900


> Message: 1
> Date: Sun, 7 Dec 2003 15:04:43 +0100
> Subject: Re: [Bf-committers] Themes, vertex size
> From: Ton Roosendaal <ton@blender.org>
> To: bf-committers@blender.org
> Reply-To: bf-committers@blender.org
> Hi,
> That's weird... it means that it works *after* it draws the vertices.
> What you changed to size 2.0 is at the end of the call, which should
> restore the setting back to default.
> This also doesn't explain why it worked in 2.28c. Are you sure about
> that?

      Yes I'm sure it worked then, I was ecstatic about being able to 
make the vertices big enough for me to see, but it may have been before 
I installed OS X 10.3, I suspect before (if I could find the receipt 
for the purchase I could say for sure, 10/25 I think, if I had the code 
base for the 2.28c release I would test that, but the daily-checkout 
archives seem to have broken in august, at least when I try http 
download thats all that shows. Is there any way to cvs a specific 
time/date co from cvs to test previous versions without the archive?). 
Also I didn't try the official release because there wasn't anything 
that needed confirming or testing because everything worked on my 
compiled version.
The bet is this is a 10.3 issue.
I'm more than happy to try any ideas for code changes/additions that 
may fix this, just say what and where.

> Anyhoo, it hints me something about a glFlush() or glFinish() that's
> missing here. But such calls should be insterted carefully, since some
> 3d cards then perform a full swapbuffers as well.
> -Ton-
> On Saturday, Dec 6, 2003, at 23:52 Europe/Amsterdam, Michael Velikanje
> wrote:
>>   Changing line 1069 to glPointSize(2.0); makes no difference,
>> changing line 1078 from glPointSize(1.0); to glPointSize(size) does
>> make it work.
>> Odd behavior: On opening blender, the vertex size is 1.0 pixel, when I
>> RMB click next to a vertex it expands to the size chosen for vertex
>> size in Themes, then reverts back to the 1.0 size on release of the
>> mouse button, the vertices only go to the chosen size when the screen
>> is forced to redraw (translate, zoom, scale LMB to move the
>> curser.............) , when a new vertex is chosen the size reverts
>> back to the 1.0 size until the screen is forced to redraw again.
>> So glPointSize is supported on OS X 10.3.1
>>   Michael Velikanje