[Bf-blender-cvs] [bfca876c05f] master: CMake: cleanup, rename INC_HD_CYCLES to SRC_HD_CYCLES_HEADERS

Campbell Barton noreply at git.blender.org
Sat Aug 27 06:33:40 CEST 2022


Commit: bfca876c05f39f74065f9d56edd7e25acfef21bf
Author: Campbell Barton
Date:   Sat Aug 27 14:08:28 2022 +1000
Branches: master
https://developer.blender.org/rBbfca876c05f39f74065f9d56edd7e25acfef21bf

CMake: cleanup, rename INC_HD_CYCLES to SRC_HD_CYCLES_HEADERS

Our convention is to use `INC_*` for include directories,
this caused `make check_cmake` to incorrectly fail as it expected
these files to be include directories.

===================================================================

M	intern/cycles/hydra/CMakeLists.txt

===================================================================

diff --git a/intern/cycles/hydra/CMakeLists.txt b/intern/cycles/hydra/CMakeLists.txt
index 2bbd46db582..db90b1b5395 100644
--- a/intern/cycles/hydra/CMakeLists.txt
+++ b/intern/cycles/hydra/CMakeLists.txt
@@ -21,7 +21,7 @@ set(LIB
 )
 cycles_external_libraries_append(LIB)
 
-set(INC_HD_CYCLES
+set(SRC_HD_CYCLES_HEADERS
   attribute.h
   camera.h
   config.h
@@ -75,7 +75,7 @@ endif()
 if(EXISTS ${USD_INCLUDE_DIR}/pxr/imaging/hgiGL)
   add_definitions(-DWITH_HYDRA_DISPLAY_DRIVER)
   list(APPEND SRC_HD_CYCLES display_driver.cpp)
-  list(APPEND INC_HD_CYCLES display_driver.h)
+  list(APPEND SRC_HD_CYCLES_HEADERS display_driver.h)
 endif()
 
 include_directories(${INC})
@@ -83,7 +83,7 @@ include_directories(SYSTEM ${INC_SYS})
 
 add_library(cycles_hydra STATIC
   ${SRC_HD_CYCLES}
-  ${INC_HD_CYCLES}
+  ${SRC_HD_CYCLES_HEADERS}
 )
 
 target_compile_options(cycles_hydra



More information about the Bf-blender-cvs mailing list