[Bf-blender-cvs] [1a8db9ec04d] master: Geometry Nodes: Rename grid output UV attribute

Hans Goudey noreply at git.blender.org
Wed Apr 7 20:23:41 CEST 2021


Commit: 1a8db9ec04d53d6b9d40d463001b84684e5a8e76
Author: Hans Goudey
Date:   Wed Apr 7 13:23:32 2021 -0500
Branches: master
https://developer.blender.org/rB1a8db9ec04d53d6b9d40d463001b84684e5a8e76

Geometry Nodes: Rename grid output UV attribute

During review of D10730 it was discovered that the "uv" name causes
issues for cycles, which uses it as a default internal data name. While
that could be fixed in the future, there was no particular reason to use
"uv" instead of "uv_map", so we use the latter instead here, which
is consistent with the lowercase naming scheme chosen for attributes.

===================================================================

M	source/blender/nodes/geometry/nodes/node_geo_mesh_primitive_grid.cc

===================================================================

diff --git a/source/blender/nodes/geometry/nodes/node_geo_mesh_primitive_grid.cc b/source/blender/nodes/geometry/nodes/node_geo_mesh_primitive_grid.cc
index 17f69886276..5bdea946238 100644
--- a/source/blender/nodes/geometry/nodes/node_geo_mesh_primitive_grid.cc
+++ b/source/blender/nodes/geometry/nodes/node_geo_mesh_primitive_grid.cc
@@ -48,7 +48,7 @@ static void calculate_uvs(
   MeshComponent mesh_component;
   mesh_component.replace(mesh, GeometryOwnershipType::Editable);
   OutputAttributePtr uv_attribute = mesh_component.attribute_try_get_for_output(
-      "uv", ATTR_DOMAIN_CORNER, CD_PROP_FLOAT2, nullptr);
+      "uv_map", ATTR_DOMAIN_CORNER, CD_PROP_FLOAT2, nullptr);
   MutableSpan<float2> uvs = uv_attribute->get_span_for_write_only<float2>();
 
   const float dx = (size_x == 0.0f) ? 0.0f : 1.0f / size_x;



More information about the Bf-blender-cvs mailing list