[Bf-blender-cvs] [7e2418a877c] functions: rename block.size() to block.capacity()

Jacques Lucke noreply at git.blender.org
Mon Jul 1 15:37:15 CEST 2019


Commit: 7e2418a877ced87eb7dc9e403dddec9dfae9fc1c
Author: Jacques Lucke
Date:   Mon Jul 1 15:26:28 2019 +0200
Branches: functions
https://developer.blender.org/rB7e2418a877ced87eb7dc9e403dddec9dfae9fc1c

rename block.size() to block.capacity()

===================================================================

M	source/blender/simulations/bparticles/particles_container.hpp

===================================================================

diff --git a/source/blender/simulations/bparticles/particles_container.hpp b/source/blender/simulations/bparticles/particles_container.hpp
index a7bcac3144b..3d4c0194e9b 100644
--- a/source/blender/simulations/bparticles/particles_container.hpp
+++ b/source/blender/simulations/bparticles/particles_container.hpp
@@ -102,7 +102,7 @@ class ParticlesBlock {
   bool is_full();
   bool is_empty();
   uint first_unused_index();
-  uint size();
+  uint capacity();
 
   ParticlesContainer &container();
 
@@ -167,12 +167,12 @@ inline uint &ParticlesBlock::active_amount()
 
 inline uint ParticlesBlock::unused_amount()
 {
-  return this->size() - m_active_amount;
+  return this->capacity() - m_active_amount;
 }
 
 inline bool ParticlesBlock::is_full()
 {
-  return m_active_amount == this->size();
+  return m_active_amount == this->capacity();
 }
 
 inline bool ParticlesBlock::is_empty()
@@ -186,7 +186,7 @@ inline uint ParticlesBlock::first_unused_index()
   return m_active_amount;
 }
 
-inline uint ParticlesBlock::size()
+inline uint ParticlesBlock::capacity()
 {
   return m_container.block_size();
 }



More information about the Bf-blender-cvs mailing list