[Bf-blender-cvs] [c09ed36] master: Minor UI incosistency reported by erickblender on irc. Twist brush is renamed to Rotate to match the tool name.

Antony Riakiotakis noreply at git.blender.org
Sun Dec 27 21:16:24 CET 2015


Commit: c09ed363bf6c6411654dc3715628d70cb5205199
Author: Antony Riakiotakis
Date:   Sun Dec 27 21:16:16 2015 +0100
Branches: master
https://developer.blender.org/rBc09ed363bf6c6411654dc3715628d70cb5205199

Minor UI incosistency reported by erickblender on irc. Twist brush is
renamed to Rotate to match the tool name.

It is not actually compulsory that the two must match since users can
change the name of a brush arbitrarily but at least try to have
consistent naming in our defaults.

===================================================================

M	source/blender/blenloader/intern/versioning_defaults.c

===================================================================

diff --git a/source/blender/blenloader/intern/versioning_defaults.c b/source/blender/blenloader/intern/versioning_defaults.c
index a9c0408..cf0e443 100644
--- a/source/blender/blenloader/intern/versioning_defaults.c
+++ b/source/blender/blenloader/intern/versioning_defaults.c
@@ -229,6 +229,13 @@ void BLO_update_defaults_startup_blend(Main *bmain)
 		if (br) {
 			br->ob_mode &= ~OB_MODE_TEXTURE_PAINT;
 		}
+
+		/* rename twist brush to rotate brush to match rotate tool */
+		br = (Brush *)BKE_libblock_find_name_ex(bmain, ID_BR, "Twist");
+		if (br)
+		{
+			rename_id(&br->id, "Rotate");
+		}
 	}
 }




More information about the Bf-blender-cvs mailing list