[Verse-dev] Misnamed: real format enum

Emil Brink verse-dev@blender.org
Wed, 5 May 2004 09:44:13 +0200 (MEST)


Eskil,

This type, from verse_header.h, is broken:

typedef enum {
	VN_FORMAT_REAL32,
	VN_FORMAT_REAL64
} VNORealFormat;

It is used for two things; object node transform subscription, and
geometry node layer subscription. It has an O in its type name, but
no _O_ in the enum symbols, which is incorrect.

I would propose either that we rename it into something more correct,
or that we simply remove it and replace it with an uint8 that has the
desired number of bits in it.

A more proper name, if we chose that solution, might be:

typedef enum {
	VN_REALFORMAT_REAL32 = 0;
	VN_REALFORMAT_REAL64;
} VNRealFormat;

Um, or something. I'm not quite happy with that either, it gets long.
But having just VN_FORMAT_ as the prefix is a bit misleading as well,
it loses the connection between prefix and actual enum type name.
Aargh.

Anyway, it's broken now, okay?

/Emil