modifier key coding Re: [Bf-funboard] Re: QKEY Functionality

Luke Wenke bf-funboard@blender.org
Thu, 23 Oct 2003 16:11:51 +1000


> Maybe a set of macros is needed to clean this all up.  We could do all the
> combos like:
>
> #define LR_CTRL ( (G.qual & LR_CTRLKEY) && !(G.qual & LR_SHIFTKEY) &&
!(G.qual
> & LR_ALTKEY) )
>
> #define LR_SHIFT_CTRL ( (G.qual & LR_CTRLKEY) && (G.qual & LR_SHIFTKEY) &&
> !(G.qual & LR_ALTKEY) )

Good idea... but maybe if could be named CTRL_MOD (Ctrl modifier only - i.e.
no shift or alt)

> (And personally I don't think we now, or should
> ever differnetiate between Left and Right mod keys, so if could be just
CTRL.

I agree.... and there would be no need for LR in the macros (I assume that
means left-right) So the macros could be:
CTRL_MOD (not alt or shift)
ALT_MOD (not ctrl or shift)
SHIFT_MOD (not ctrl or alt)
CTRL_SHIFT_MOD (not alt)
CTRL_ALT MOD (not shift) <- not sure if this should be included.
ALT_SHIFT MOD (not ctrl)
NO_MOD (not ctrl, alt, or shift)
There's also ctrl-shift-alt but that is probably a bad idea.

- Luke.